Authentication issues on Kpler's web terminal - China

Incident Report for Kpler

Resolved

This incident has been resolved
Posted May 21, 2026 - 13:41 UTC

Investigating

We are currently investigating the issue of China-based users not being able to access Kpler's web terminal.
Posted May 20, 2026 - 16:50 UTC
This incident affected: Authentication.