Cloudflare is blocking access to the Marine Traffic web terminal for some users

Incident Report for Kpler

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 20:07 UTC

Investigating

Cloudflare is blocking access to the Marine Traffic web terminal for some users. Our team is actively investigating and working to resolve this as soon as possible.
Posted Sep 10, 2026 - 18:53 UTC
This incident affected: MarineTraffic (UI).