Notice: Delay in today's run 00z forecast publication

Incident Report for Kpler

Resolved

This incident has been resolved and the affected runs have been backfilled.
Posted Jul 16, 2026 - 14:36 UTC

Investigating

We are currently investigating a delay in publishing today's 00z forecasts across all weather models. This affects our load, wind, solar, hydro run-of-river, dispatchable generation, and day-ahead price forecasts.

We are working to publish as soon as possible and will keep you updated as we progress.
Posted Jul 16, 2026 - 08:08 UTC
This incident affected: Commodities (Power).